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PART Ⅰ

Foreword 

WinEG2007 
WinEG2007 is designed for field work, it can run on WinCE operating system and 
also suitable for your PC. WinEG2007 is Easy to operate, Powerful, User-friendly, and 
Practical. 
 
Copyright   
This manual will introduce you how to use WinEG2007. We suggest you read it 
carefully.  
All copyrights of the manual are reserved by our company. In the scope of copyright 
protection, reproduction, adaptation will be prohibited without the written consent of 
company. 
 
Registered trademarks 
AutoCAD, WinCE is registered trademarks. All those trademarks are the property of 
their respective owners.  
 
Technical Service 
From the day you buy WinEG2007, you have the right to ask for our after service. 
Mail-box: softspt@vip.sina.com. 
 
Hardware 
High efficiency ARM or MIPS CPU 
16MB memory 
320×240 Touch screen 
Serial and USB port 
Pen 
 
Software 
WinEG2007 is only suitable for the win total station with Microsoft Windows CE.net 
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Components: 

 name Unit 
1 WinEG2007 manual 1 
2 Total Station Communication Cable 1 

Caution: 
When you use the command of Save, Save As, Coord Export, and File Export in 
WinEG2007, do save all the new files in the default file location SouthDisk 
  

1. Introduction of WinEG2007 
 
Power: Press the power key on the up right of the keyboard. See the following figure. 

 
Win Total Station Interface 

 
Run WinEG2007: Double click the icon of WinEG2007 on the desk. 
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1.1 Interface 

See the following figure “interface”: 

 

 Interface 

In the interface of WinEG2007, from left to right we have pull-down menus: FILE, 
Meas, Edit, S.O., Tool, Setup, and icon: Attribute, Backspace, Redo, and Window 
for Surveying. 
View tool bar: Zoom in, Zoom out, Annotation Text Delete, Move, Windowing, Full 
Screen, Previous, Refresh, Annotation Text,  
Window for angle and distance: HA, VA, SD. 
On the right of the screen is window for surveying. 

1.2 Pull-Down Menu 

File 
Click File, See the following figure: 
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File 

The options of file list are as follows: 
New: Create a new graphic file; it will be automatically saved in the folder of 
“~$Wineg$.%%%”before you save it. 
Open: Open an existing graphic file (*.prj). 
Save: Save the information of the graphic file (*.prj). 
Save As: Save the current graphic file as another completely different file. 
Import: Input the coordinated point into the current graphic file. There are two 
different ways of import: Manual Entry and Auto Import. 
Export: Create Cass file (*.dat). 
Exit: Quit the WinMG2007. 
 
Meas 
Click the Meas in the menu, we get the following figure: 

 

Meas 

The options of file list are as follows: 
Occ & BS Set We need a backsight to start the process of surveying, there are two 
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ways BS Orientation and Azimuth Orientation. 
X-Sect: We measure the points on the cross section, and work out the distance and 
height difference. 
REM: REM can help you obtain the target height. Especially when the target is much 
higher than the place that you can put the prism on. 
Recalculate: According to the raw data, we recalculate the current graphic file. 
Occ in the center: Move the Occ point to the center of the screen, and show the whole 
figure in current scale. 
Current Pt in the center: Move the latest point to the center of the screen, and show the 
whole figure in current scale. 
Edit 
Click Edit, see the following figure: 

    

Edit 

The items of this menu are as follows: 
Coord Data: By clicking this item, you can browse, delete, and edit the coordinate 
data, see the following figure.  

 

Edit 
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Caution: You can adjust the width of the list to see the whole information. 
Raw Data: You can browse the raw data here. 

 
Raw data 

 

Fill-Cut Data: By clicking this command, you can browse the Occ Pt and BS Pt, but 
the data is unchangeable. 

 
Fill-Cut Data 

Alignment Data: Work out the coordinates and height according to the Horizontal 
alignment data and Vertical alignment data; show you the figure of vertical section, 
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S.O. 
Click S.O., you will get the following figure: 

 

S.O. 

The items of this menu are as follows 
Radiate: setout points with the distance and angle that exist between station and setout 
point. 
Point: Layout points. 
Line: Layout line, curve and arc. 
Plane: Layout slope-plane, three points-plane, arc-plane. 
Road Layout: Layout roads. 
 

Tool 
Click, Tool, you will get the following figure: 

 
 Tool 
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The items of this menu are as follows: 
COGO: Under this menu, there are many ways to calculate unknown parameters, such 
as Intersection, Resection, etc. see the following figure. 

 
 COGO 

Area: Calculate the area of any figure which is composed by points (at least three, 
non-collinear), or polygonal line. 
Inverse: work out the coordinates with a known point, a distance and azimuth angle 
Reverse: work out the distance and angle with three known points. 
 
Setup 
Click setup, then you get the following figure: 

   
   Setup 

The items of this menu are as follows: 
System Setup; Here you can set the Screen Capture, Coord Info, 4 Points Ground 
Feature, Sheet Line System, Power, Quick Draw Mode, Distance Unit, North Arrow. 
Project: You can check the creating data and version of project files with this function. 
Unit Set; Set up the unit of angle distance pressure and temp. 
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Measurement Set; Set the Tilt, Atmospheric correction parameters, Vertical angel 
mode. 
Support: http://www.southinstrument.com 
System Information: Copyright and version. 
 

Tool Bar 

Tool bar shows you the common functions of surveying and mapping. Here is the brief 
introduction of them; 

  Control the window for surveying by hiding or showing the window. 

 

Zoom in Zoom out 

Pan Windowing 

Zoom all Previous 

Refresh Annotation Text

Delete 
Annotation Text Attribute 

Backspace Revoke 

The windows for surveying on the left of the 
screen are as follows. 
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2. Meas→X-sect  

2.1 New Project     

Click File—New to create a new project, but the project do not have its name, so we 
suggest save the project and name it.  
 

2.2 Input Control Point 

We should input control points before start surveying, There are two different ways of 
import: Manual Entry and Auto Import. 

 
Coord Import 

 

Click File→Import→Manual Entry, see the shown figure above. 
The default name of the point is Pt1, and it will be automatically accumulated 
according to the former point. We input 4 points as the following excel.  
 

Pt no. Pt name X Y Z 
1 Pt1 100 200 22 

2 Pt2 200 200 22 
3 Pt3 300 80 21 
4 Pt4 250 40 20 

 
After inputting, Click  you can see the following figure with four control points: 
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Control points 

 

2.3 Occ & BS Set  

Click Meas→Occ & BS Set, you will get the following figure, there are two ways BS 
Orientation and Azimuth Orientation, here we choose the BS Orientation.   

 
Backsight 

Input the Occ, BS, and inst.Ht then aim the BS point and click the √ key. Then you 

can see an Occ point  and a BS point  on the screen. See the following figure.    
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Occ & BS set 

2.4 Meas→X-sect 

Click Meas→X-sect, then you get the following figure. 

 
X-sect 

As the figure shown above, input or select the name of the road. Also see 
Edit→Alignment to know how to define a road. Input chainage, click Next: obverse 
center line point, you will get the following figure: “middle chainage”. 

 11 



WinEG2007 

 
Middle Chainage 

Input the code and Prism height turn the total station to the prism on the middle 
chainage, click Meas, you will get the figure shown above: “Middle chainage”. Click 
browse, you will get the dialog: “raw data for x-sect”, see the following figure. Click 
Last step: transect set, you will get the following dialog “transect mesa”, now you can 
go on with the next middle chainage. Click Next step: Transect Point Measurement, 
the data in the figure “Middle Chainage” will be saved in the “Transect Meas” dialog. 
Click Resetup the system will make it turn back to the interface of Occ & BS. 

 

Middle Chainage 
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Raw Data for X-sect 

 

   Transect Meas 

 

Input the code and prism height, then aim the total station at the prism on the middle 
chainage, Click Meas; you will see the following figure: “Transect Data” click 
Browse; you can check the raw data, as shown in the figure “Raw Data for X-sect” 
below. click Last step: middle chainage Meas, you will turn back to the dialog” 
Middle Chainage”. Click Save transect point measurement, the observation data will 
be saved. 
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Transect Data 

Caution: When you edit the code which is the same as the code of chainage, you will 
get the following dialog. 

 
Prompt Dialog Box 1 

When the code you need to edit has been existed. you will get the following dialog: 

 
Prompt Dialog Box 2 

Click “Yes” button, the existing data will be covered, click “No” button, it will turn 
back to the Meas. interface, you can change the code and save it.   
  
Click the “browse” button; you can check the information of all the points 
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3. Meas→REM  

Meas→REM 

Click: Meas→REM, see the following figure: “REM” 

 
REM 

Input the prism height, aim the station to the prism, and click the Observation button 
in the Aim at the prism part. then you will get the VA and SD value, see the figure” 
Observation Data with Prism”. 
Turn the station and aim the target point, click the Observation button in the Aim at 
Target Part. Then you will get the VA and SD value, see the figure: “Observation Data 
without Target”. 

 

Observation Data with Prism  
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                                Observation Data of Target  

4. Meas→Coord 

Setting Occupied Point   

 

 
Occ set 

 
As the figure shown above, input the point number: Pt4, P.Ht: 1.5, aim to the prism. 

Choose and click mesa, the system will work out angle, distance as the 

following figure shows:  
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Click Rec., you can save the data, and then Rec. button becomes unavailable, till new 
data is collected. 

 

Record 
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5. Edit→Coord Data 

Edit→Coord Data 

Click: Edit→Coord Data, you will get the following figure: “Coord Data” 

 

Coord. Data   

Delete Coord. data: Click the point you want to delete (for example: Pt1).See the 
following figure: “Delete Coord Data”, then click Delete, the point you selected will 
be deleted. 
Edit Coord. data: Double click the point then the software will show you the dialog of 
Coord Editing, as shown in the following figure “cord edit”. You can edit the point 
name and the value of the point here 
 

 
Delete Coord Data 
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Coord edit 

 

 

6. Edit→Alignment Data 
 

6.1 Edit→Alignment Data 

 
Click Edit→Alignment Data, you will see the following figure “road data”. 

 

Road data 

The left of the dialog will show you the existing road in the current project, see the 
figure shown above. The window on the top-right corner will show you the graphic 
horizontal alignment. The lower right corner will show you the graph of vertical 
alignment. 
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Del.: delete the road data. 
Edit: edit the road you select. 
Add: add a new road. 
Import: import a road into the station. 
Export: export the selected road (*.rod). 
 

6.2 Add Road 

Click Add in the dialog “road data”, you will get the following figure: “Add Road”. 

 
Add Road 

Input the name of the road, for example: road1, choose “Vertical curve” under V-Sect 
type, see the following figure: “V-Sect type” click Ok you will see the interface “Add 
the Start Point”, if you haven’t input the road name, the system will ask you for it. 

 

V-Sect Type 
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Add the Start Point 

 

6.3 Edit the Start Point of the Road 

As the figure shown above “add the star point”, there are two ways of inputting start 
point: first, select the point in the list, second, in put the point manually. 
Point No.: point number  
Point Name: point name 
N: X coordinates. 
E: Y coordinates. 
Z: Z coordinates. 
Chainage: chainage, unit: m. 
Click List, you will get the following figure “Select the Start Point of Road” here, you 
can select a start point, for example: we choose point 1, now the data is added in, as 
shown in the following figure: “Start Point of the Road” 

 
Select the Start Point 
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Start Point of the Road 

 

Input the chainage of the start point, for example: 300. Click save, the system will 
turn to the interface of: “Horizontal alignment inputting”. 

Caution: No matter you input the cord of start point with hands or select it in the list 
you must click save. If you didn’t input the value of the points, just click save, the 
Coord will be saved like this: N=0, E=0, Z=0. Chainage=0. 

 

                           Horizontal Alignment Inputting 

 

6.4 Edit Horizontal Alignment 

Horizontal Alignment data includes: Points, line, arc, curve. See the figure above 
“Horizontal alignment inputting”. 
Del.: Delete the Horizontal Alignment data. 
Edit: Edit the horizontal alignment data. 
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Insert: Insert point, line, arc, and curve. 
Add: Add point, line, arc, and curve. 
Click Add, here we add “line” into horizontal alignment data, choose line in the 
interface: “Choose Horizontal Alignment”, system will show you the figure “input 
line”; here you can set the length and azimuth. Click OK, save the data and turn back 
to the interface: “Horizontal alignment inputting”. Click X, the data will not be saved 
but the system still turns back to the inputting interface. When the data is added 
successfully the system will show you the figure on the screen. 

 

Choose Element of Horizontal Alignment 

 

 

Input Line 

 

 
In the interface: “Choose Horizontal Alignment Data” click Arc, the system will show 
you the figure “Input Arc”, Radius and length, in the Turn list choose “Left”, click 
OK, save the data and turn back to the interface “Horizontal alignment inputting”, 

 23 



WinEG2007 

click X. the curve data will not be saved and it will automatically turn back to the 
figure “Input Arc”. 

 

Input Arc 

 

In the interface: “Choose Horizontal Alignment Data” click “curve”, you will get the 
following figure “Input Curve”. Here you can input Radius and Length; in the Turn 
list choose turn left. Click OK, save the data and turn back to the interface: 
“Horizontal alignment inputting”. 

 

Input Curve  

In the interface: “Choose Horizontal Alignment Data” click “Point”, you will get the 
interface of “Input Point”. There are two ways of inputting points: First, Input the data 
manually. Second, input the data by clicking the Select from list button, then you will 
get the following figure: “select the point”, now double click the point and input 
radius, Former transitional curve length, and latter transition curve length. Click OK, 
save the data and turn back to the interface of “Horizontal Alignment Inputting”. 
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Input Point 

 

 

 Select Point 

 

As shown in the following figure: “Data of H AL” you can see the graph. Add, Edit, 
Insert, Del can help you to edit, insert, and delete the data.  
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Data of H AL 

 

6.5 Edit Vertical Alignment Data 

 
The Vertical Alignment Data includes: intersection, Elevation, and Distance. See the 
following figure. 

 
Data of V AL 

 
Add: Add a new line for inputting vertical alignment data. 
Insert: Insert a new line for inputting vertical alignment data. 
Delete: Delete the vertical alignment data. 
Save: Save the vertical alignment data, we suggest you to save the data. 
Click Add, the system will show you the interface “Add vertical data” now click the 
white space in the line and input the data with keyboard. See the following figure: 
“Vertical alignment data inputting”. We input a group of vertical data according to the 
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following excels:  
Intersection Elevation distance

400 40 60 
500 35 50 
600 25 70 
700 30 60 

 

 

Add Vertical data  

 

 

Vertical alignment data inputting 

 

After you input all the data, click Save. You will get the following figure. “Data of 
vertical alignment”. 
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Data of Vertical Alignment 

 

After we add all the vertical alignment data, we can enter the transect part by clicking 
“transect”; you will get the following figure “Transect”. 

 
Transect 

 

6.6 Edit Transect  

Transect data includes: chainage, left side model, right side model. 
Add: Add a blank line for inputting the transect data. 
Insert: Insert a blank line for transect 
Del.: Delete the transect. 
Save: Save the transect data. After you edit the transect data, please save before 
continuing. 
Template: Add new template, check the original template and edit the current 
template. 
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Click Template, you will get the following figure: “section template”. section template 
data includes: section name, horizontal offset, gradient％, vertical offset distance. 
New: Create a new template. 
Delete: Delete the template. 
Save: Save the template. 
Add section: Add new section. 
Del. section: Delete section. 
Input the section name, and click New, you will get the figure: “Create new section 
template”. 

 

Section template 

 

 

Create new section template 

Click OK in the interface of “create new section template “then click Add section, you 
will get the following figure: “add section”. Input the section name (default value is 
Z1): 

Horizontal offset: 12 

 29 



WinEG2007 

Vertical offset: 2.5  
Gradient%: 0.3; Select Up; see the following figure” Z1 section”. 

 
Add section 

 

 

Section Z1 

 

Click OK, add the Z1 section, and continue with the new sections. 
Z2: horizontal offset: 3, vertical offset: 2.5, and choose Down button.  
Z3: horizontal offset: 5, vertical offset: 0, and choose Up button. 
Now we create a new template, its name is sect1. See the following figure: “Section 1” 
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Section 1   

 

 

Section 1 (with figure) 

 

In the figure: “Transect” shown above, click Add, you will get a window: “Add 
Transect”. Here you can input chainage and click the blank under right/left model 
setting you will get the interface: “select template” and now choose section 1 form the 
list, click OK, see the following figure: “Transect data”. 
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Add transect 

 

 
Select template 

 

 

Transect data. 

Click Calculate the road points tab; enter the interface of “Calculate the road point”. 
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Calculate the road point 

 

6.7 Calculate the Road Point 

Road point include: middle point, right point, left point, added chainage, added integer 
chainage. 
Select middle Pt and added chainage, input increment, click Calc.; the software will 
work out the point and show you on the screen. 
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7. S.O.→Radiation 

7.1 File→Import 

Also see Meas→X-sect→Input Control point 
 

7.2 Meas→Occ & BS 

Also see Meas→X-sect→Occ & BS. 
 

7.3 S.O.→Radiation 

Click S.O.→Radiate menu, you will get the following figure: “Radiate”: 

 
Radiate 

Click Pick, here is a dropdown list, see the following figure: 
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From List: once user clicks list select button, coordinate view dialogue box would 
pop up, use pen to click the coordinate item needed to setout, selected setout point 
name would be shown in setout point input box. The angle offset between setout point 
and zero direction would be shown on 2nd area of information display area at downside 
of the screen. As picture showed “Setout 1”: 
 
Interface instruction: in graph “Setout 1”: “1st area” is for Occ information, 
displaying azimuth, zenith and SD; “2nd area” is for offset display area, showing the 
offset of the Setout point and real point about angle, distance and elevation. When 
each item is zero, that means real observing point and Setout point are same point; 
“3rd area” is for controlling. Find out the accurate point in practical field by moving 
prism upward, forward, leftward or rightward. When the value is negative that 
delicates it should be moved toward opposite direction; “4th area” is for coordinate 
display which include showing northing coordinate, easting coordinate and elevation 
in real time. 

  

  
Setout 1 

Rotate telescope to make angle offset close to zero, then the direction telescope aim at 
is the direction where the Setout point is. After inputting prism height, put prism on 
the direction corresponding to telescope’s direction. Click “S.O.” after sighting prism. 
As picture shows “Setout 2”: 
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Setout 2 

Repeat steps of “Move prism→Click S.O.”, until each index reaches required 
conditions. 
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8. S.O.→Point 
 

8.1 File→Coord Import 

See Meas→X-sect→Input the Control Point for details. 
 

8.2 Meas→Occ& BS Set 

See Meas→X-sect→Occ & BS Set for details. 

8.3 S.O.→Point 

Click S.O.→Point, you will get the following dialog. 
The interface of point setout is same as interface of radiation setout; refer to the 
“Interface Introduction” for the information of each area. 

 
Point setout 

 

Designed value: Click “Design”, you will get the following dialog: 
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Input coord of designed Pt          Select setout Pt 

 

1. Input the coordinate of the setout Pt directly. Users can input coordinates of the 
setout Pt into Input coord dialog, click OK to start setting out. （The coordinate won't 
be saved in this method.） 
2. Click “Pick”, the selecting dialog of LIST and ADD Coord will show at the bottom 
of Input coord interface, see figure “Select setout Pt”. 
 
Meas: to carry out measuring of distance and angle, calculate and show the difference 
between the designed point and real-measured point according to the input designed 
data. See figure “Calculated result of Pt setout”.  
Rotate the telescope to make the Angle diff. as 0, then the current direction in which 
the telescope is shooting is the direction of the setout Pt. Then after inputting prism 
height, place the prism in that direction. Use telescope to collimate the prism, then 
click “Meas”, repeat the operation of “moving prism→Measuring”, until each indexes 
meet the precision requirement of setout, the Pt setting out is finished. 
 
Close: to quit the Pt setout interface. 
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Calculated result of Pt setout 

9. S.O.→Line→Poly Line 
Principle; Use starting point and ending point to define a line segment, use the 
measured result to make the setout point on the defined line segment.  

Steps: Same as Pt setout. 
 

S.O.→Line→Poly Line 

Click S.O.→Line→Poly Line, you will get the following dialog. 

 

Line segment setout 

The interface placement of line segment setout is same as radiation setout; refer to the 
“Interface Introduction” for the information of each area. 
Designed value: click “Design”, you will get the following dialog, see figure “Input 
line design parameter.”  
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Input line design parameter 
1. Input coordinates of starting Pt and ending Pt directly: Users can input coordinates 
of the setout segment into Input coord dialog, click OK to start setting out. （The 
coordinate won't be saved in this method.） 
2. click “Pick”, the selecting dialog of LIST and ADD Coord will show at the bottom 
of Input coord interface, select or add the coordinate of starting Pt or ending Pt which 
are used to define a segment, see figure “Segment info”, and click OK to start setting 
out. 
 

 

Segment information  

Meas: to carry out measuring of distance and angle, calculate and show the difference 
between the designed segment and real-measured point, according to the input 
designed data. See figure “Calculated result of line segment setout”.  
Repeat the operation of “moving prism→Measuring”; until each index meets the 
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precision requirement of setout, the line segment setting out is finished. 
Close: to quit the line segment setout interface. 

 

Calculated result of line segment setout 
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10. S.O.→Line→Arc 
Principle: Use starting Pt, ending Pt and any Point on the arc to define an arc. Refer 
to measurement result to make the setout points on the defined arc.  
Steps: same as line segment setout. 
S.O.→Line→Arc 
Click S.O.→Line→Arc, you will get the following dialog: 

 
Arc setout 

The interface placement of arc segment setout is same as radiate setout; refer to the 
“Interface Introduction" for the information of each area. 
Designed value: Click “Design”, you will get the following dialog. See figure “Input 
arc parameter”: 

 
Input arc parameter 
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1. Input coordinates of starting Pt, ending Pt and any one Pt on the arc directly. Users 
can input coordinates of the setout arc into Input Coord. dialog; click Yes to start 
setting out. （The coordinate won't be saved in this method.） 
2. Click “Pick”, the selecting dialog of List and Add Coord will show at the bottom of 
Input coord interface, select or add the coordinate of start Pt, end Pt and one 
discretional point on the arc which are used to define an arc, see figure “Arc 
information”, and click Yes to start setting out. 

 
Arc Information  

 
Meas: to carry out measuring of distance and angle, calculate and show the difference 
between the designed arc and real-measured point, according to the input designed 
data. See figure “Calculated result of arc setout”.  
Repeat the operation of “moving prism→Measuring”; until each index meets the 
precision requirement of setout, the line arc setting out is finished. 
Close: to quit the arc setout interface. 
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Calculated result of arc setout 
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11. S.O.→Plane→Slope 
 

Principle: define a slope, according to starting point, ending point, elevation, 
gradient and direction of slope. 
 

Steps: Same as Arc Setout. 

S.O.→Plane→Slope 

Click S.O.→Plane→Slope, you will get the following dialog: 

 

Slope Setout 

Designed value: Click “Designed value”, you will get the following dialog: 

 

Input parameters of slope 
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1. Input coordinates of starting Pt, ending Pt, elevation, gradient and direction of slope 
directly. Users can input coordinates of the setout slope into Input coord dialog, click 
Yes to start setting out. （The coordinate won't be saved in this method.） 
2. Click “Pick”, the selecting dialog of List and Add Coordinate will show at the 
bottom of Input coord interface, select or add the coordinate of starting Pt, ending Pt, 
elevation, gradient and direction of slope which are used to define a slope, see figure 
“Slope info”, click yes to start setting out. 

 

Slope info 

 

Meas: to carry out measuring of distance and angle, calculate and show the difference 
between the designed slope and real-measured point according to the input designed 
data. See figure “Calculated result of slope setout”. Repeat the operation of “moving 
prism→Measuring”, until each indexes meet the precision requirement of setout, the 
plane slope setting out is finished. 
 
Close: to quit plane slope setout interface. 
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Calculated result of slope setout 
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12. S.O.→Plane→3 Pts plane 
 

Principle: Define a plane with three points. 
 

Steps: Same as slope Setout. 
 

S.O.→Plane→3 Pts plane 

Click S.O.→Plane→3 Pts plane, you will get the following dialog: 

 

Three Pts plane 

Designed value: Click “Designed value”, you will get the following dialog: 

 

Input parameters 
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1. Input coordinates of point 1, point 2, and point 3 directly. Users can input 
coordinates into Input coord dialog, click Yes to start setting out. （The coordinate 
won't be saved in this method.） 
2. Click “Pick”, the selecting dialog of LIST and ADD Coord Will show at the bottom 
of Input coord interface, select or add the coordinate of point 1, point 2, point 3 which 
are used to define a plane, click yes to start setting out. 
 
Meas: to carry out measuring of distance and angle, calculate and show the difference 
between the designed plane and real-measured point according to the input designed 
data. See figure “Calculated result of three Pts plane setout”. Repeat the operation of 
“moving prism→Measuring”, until each index meet the precision requirement of 
setout. 
 
Close: to quit three Pts plane setout interface. 

 

Calculated result of three Pts plane setout 
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13. S.O.→Plane→Arc plane
 

Principle: define an arc plane according to three points. 
 

Steps: Same as slope Setout. 

S.O.→Plane→Arc plane 

Click S.O.→Plane→Arc plane, you will get the following dialog: 

 

Arc plane Setout 

 

Designed value: Click “Designed value”, you will get the following dialog: 

 

Input parameters 
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1. Input coordinates of starting Pt, ending Pt, any pt on arc line, elevation of arc line, 
gradient, and direction of plane directly. Users can input coordinates of the setout arc 
plane into Input coord dialog, click Yes to start setting out. （The coordinate won't be 
saved in this method.） 
2. Click “Pick”, the selecting dialog of LIST and ADD Coord will show at the bottom 
of Input coord interface, select or add the coordinate of starting Pt, ending Pt, any pt 
on arc line, elevation of arc line, gradient, direction of plane which are used to define a 
arc plane, see figure “Arc plane info”, click Yes to start setting out. 

 

Arc plane info 

 

Meas: to carry out measuring of distance and angle, and calculate and show the 
difference between the designed plane and real-measured point according to the input 
designed data. See figure “Calculated result of arc plane setout”. Repeat the operation 
of “moving prism→Measuring”, until each indexes meet the precision requirement of 
setout. 
 
Close: to quit arc plane setout interface. 
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Calculated result of arc plane setout 
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14. S.O.→Road 
 
Principle: define a road with designed road data. 
 

S.O.→Road 

Click S.O.→Road, you will get the following dialog: 

 
Road Setout 

 
（1）Select road needed to setout from the dropdown list, as picture shown below: 

 
Selecting road 
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After selecting, plane map of road would be drawn on the screen as shown below: 
（2）Input Setout chainage in chainage edit box 
（3）Select leftside or rightside of the midline. If leftside is selected. Click Right, and 
then if user needs to go back to rightside, click that button again. Input the distance 
between point and midline. 
（4）Click Information, as “Road Setout information” interface shown below. 
（5）Click Layout point position, as picture shown below: 
（6）Click Layout, as picture shown below: 

 
Road plane graph 

 

 
Road Setout information 
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Layout point position 

 

 
Road point setout 

 
（7）Click S.O. in road Setout. Carry out measuring of distance and angle, calculate 
and show the difference between the designed chainage and real-measured point 
according to the input designed data. See figure “Calculated result of road setout”. 
Repeat the operation of “moving prism→Measuring”, until each index meet the 
precision requirement of setout. 
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Calculated result of road Setout 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 56 



WinEG2007 

15. Function Introduction 

15.1 File Menu 

 
File Menu 

 

 
1. New Project 
Function: Create a project file with suffix * .prj. 
Operation: Click File→New, the system creates a blank job. 
Note: When you create a new project during viewing last project, the system will ask 
whether to save project. Click Yes or No according to the needs. 
 
2. Open project 
Function: Open an existed project file with suffix * .prj. 
Operation: Click File→Open, you will get the following dialog, see figure “File 

selecting dialog" select the project file you need. 
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Select a File 

Note: System will shut the current project off when you open a new project. Note to 
save the work.  

 
3. Save 
Function: Save current project. 
Operation: Click File→Save, the system will save the project in your selected file 
route, with the format of *.prj. See figure “Save file”: 

 
Save a file 

Note: If this is the first time to save the project, system will ask you to select a proper 
file name for the project. （see figure “Save file”）. When saving a project, users must 
save data into the disc directory of Genius software, i.e.: "SouthDisk". If the data is 
saved to other directory, it will be cleaned out after removing the battery. 
 
4. Save as 
Function: Save the current file with another name.  
Operation: Click File→Save as, you will get the “Save as” dialog. Save it with a 
proper file name. 

Note: When saving the file with another name, the project must be saved into the 
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“SouthDisk” directory. 
5. Coord Import 
Function: Import the known coordinate to current project file. There are two methods 
to input: Manually Entry and Auto Import. 
Operation: Click File→Import→Manual Entry, you will get the following dialog, 
input the Pt name and coordinates and then click OK, The input data of Pt coordinate 
will be saved to Project coordinate database. The system prompts to input the next 
point. After inputting coordinates, click × to quit Input Coord 

 
Input Coord 

 

Click File→Import→Auto Import, you will get the following dialog, select the data 
file（*.dat）which you need to import into this project. Click OK to confirm the 
importing. See figure “Open coord data”: 

 
Open coord data 
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6. Export 
Function: Export coord data file to create CASS coord data file（*.dat） 
Operation: Click File→Export, you will get the Save as dialog, input the file name, 
and then the coord data can be saved as *.dat format.  
 
7. Exit 
Function: to quit this software. System will give prompt to ask if you really need to 
save current project. 

 

15.2 Meas Menu 

 
Meas Menu 

1. Occ & BS Set 
Before collecting or setting out data, occupied point and backsight point must be set; 
otherwise all measured coord data are incorrect. Before Occ & BS Setting, known 
points have to be input first.  
There are 2 ways to set the Occ & BS points: BS Orientation and Azimuth Orientation. 
 
BS Orientation: 
Click: Meas→Occ and BS Set, you will get the following dialog, see figure “BS 
Orientation”, Select BS Orientation, the cursor first locates in Occ editing box. There 
are two ways to input Occ Pt: one is to press the numeric keys on the display board to 
input directly. If the Pt# doesn’t exist, after clicking √, there would be a Notice: “Occ 
coordinate does not exist! Need to input manually?”. The other one is that using the 
pen to select known point or control point on the touch screen. This requires zooming 
out the Occ Pt and BS Pt to current view. The two methods can be used to input BS 
point. 
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During orientation, the Inst. Ht is default as 1.5m, use steel tape to measure the Inst. 
Ht. accurately, and input this accurate value to the Inst. Ht item. 
After inputting, rotate the telescope to sight the orientation Pt precisely, click √ to 
finish Occ & BS orientation. System will prompt: “Occ has been set 
successfully……”, and then an Occ symbol shows at the occupied point, and a dotted 
line appears to connect occupied point and orientation point, indicating that orientation 
has been finished.  

 
BS Orientation 

If there are checking points（known points）, you can check Occ Pt and orientation Pt. 
See figure “Check Occ Pt”. Input Occ Pt, BS Pt and check Pt, and then click √ before 
Check, system prompts “1. Sight check point. 2. Press “OK” to start checking. See 
figure “Check Notice”. Press OK to return to check result, see figure Check result. If 
the check result is disqualified, click No, system will return to the interface of Check 
Occ Pt. Users can adjust the telescope and do the Occ Pt checking again. Repeat this 
until the checking result is qualified, and then click Yes to finish Occ Pt checking.  
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Check Occ Pt  

 

Check Notice 

 
Check result 

 

Azimuth Orientation: 
In the Occ Pt checking box select Azimuth Orientation, see figure “Azimuth Orientation”, 
the BS changed into Azimuth, which requires to input BS azimuth as per the format of 
“degree, minute, second” manually. Other operations are same as BS Orientation. 

 
Azimuth Orientation 
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2. X-Sect 

After setting Occ, click Meas→X-Sect, as graph ‘X-Sect’: 

 
X-Sect 

 

Setting occupied point before measuring transect. After that, click Meas→X-Sect, 
then get into window of measuring transects. 
At the first time of measuring transect, user can input number of the road needed to 
measuring transect in the road list. Then input chainage in rightside chainage box, 
such as “Set road and chainage”: 

 
Set road and chainage 

 

Click “Next: observe center line point” to get into midchainage observing window, as 
“Midchainage observing”: 

 63 



WinEG2007 

 
Midchainage observing 

 

After inputting chainage code and prism height, rotating telescope to sight at prism on 
midchainage, click “Next: observe center line point”. Window will show the observing 
result when measuring step is over, as picture show “Midchainage measuring results”: 

 
Midchainage measuring results 

After measuring midchainage, click “Next step: transect point measurement” to get 
into the measuring step for transect point, as picture shows “Transect observing”: 
If at this time, it is required to reset transect, click “Last step: Transect set”, system 
will save the transect data already measured, and to enter into next transect observing 
step. 
If at this time, user finds that error of Occ setting or Occ has been changed, you can 
click “Resetup” to get back to Occ setting window. After user sets Occ correctly, 
system will get back to “Midchainage observing” dialogue box. 
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Transect observing 

When observing the transect, transect point code will accumulate automatically and 
user can change the code and prism height. 
After rotating the telescope to sight prism put on transect, click “Meas” to enter into 
window for transect point observing. When a transect point measurement is completed, 
click “Save transect point measurement” to save the observing data. System will show 
automatically next window for transect observing, code will accumulate 1; prism 
height will be the same as last time. 
Notice: If user has changed code, and code is the same as midchainage code, system 
will pop up a notice box, show as picture “Notice 1”. 

 
Notice 1 

 

If user has changed code, and the transect code has already existed at former transect 
code, system will also pop up a notice box, show as picture” Notice 2”. 

 
Notice 2 
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Clicking “Yes” will cover all of the measured data, if click “No”, system will turn 
back to transect point observing window to wait for modifying code and save transect 
observing data again. 
Click “Browse” in window of transect observing, all of the Occ and observing 
information could be viewed. Click “×”to quit transects observing. 
 
 
3. REM 
Click Meas→REM to get into remote height window, show as picture “REM”: 

 
REM 

In REM dialogue box, default prism height is empty; user can change the prism 
height. 
First step: Rotate telescope to sight at the prism on basic point and click “Observation”, 
system will show back the vertical angle and SD of prism, as picture shows “Sight 
prism”: 

 
Sight prism 

Second step: Rotate telescope to sight the point needed to observe, click 
“Observation”, system will show back the vertical angle of observing point and show 
the result of the height of observing point. Show as picture “Calculation results”: 
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Calculation results 

 

Notice: If user need to change the prism height after calculation result showed, then 
need to click “Observation” to recalculate remote height. 
 
4. Coordinate recalculation 
This function recalculates coordinate data of drawing graph, according to raw data. 
User should use this function to recalculate coordinate after modifying error of raw 
data. 
Click menus in turn: Meas→Inverse, as graph “Inverse menu” below: 

 
Inverse menu 

 

Dialogue box showing as below will pop up: 
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Coordinate recalculation notice 

 

Click “Yes” to recalculate, click “No” to turn back to software main window. 
 
5. Centering the Occ 
In measuring process, surveyor usually needs to find the location of Occ quickly. 
Click Meas→Occ In The Center, current Occ would be centered and shown on screen. 
The display scale would be the same as before. As picture shows below: 

  
Centering Occ 
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6. Centering point 
This function could make the last measured point centered and shown on screen. 
Click menus in turn: Meas→Current Pt in The Center, as picture shown below: 

 

Centering point menu 

 

At this time, the 4th point measured would be centered and shown on screen, shown as 
picture: 

 

Center and display point 
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15.3 Edit menu 

 
Edit menu 

 

15.3.1 Coordinate data 
Click Edit→Coord data, show as picture below: 

 

Edit menu for coordinate data 

 

Click “Coord data” to get into view coordinate dialogue box, shown as picture below: 
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View coordinate data 

Contents shown in “View coordinate” window by sequence are point number, point 
name, coordinate X, coordinate Y, coordinate Z. Use pen click one of coordinate 
records. System will pop up edit window of this coordinate record, as picture shown 
below:  

 
Edit coordinate 

User could edit the point name and coordinate of this point with coordinate edit 
window. 
Click “OK” to confirm edit after modifying the coordinate and turn back to coordinate 
view dialogue box or click “×”directly to cancel edit and turn back to coordinate view 
dialogue box. 
If user needs to delete one coordinate record, could use pen choose this record, and 
click “Delete” in coordinate view window to delete record. 
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15.3.2 Raw Data 
Click Edit→Raw data, as picture showed below “View raw data”: 

 
View raw data 

Occ information, position information and sight point information of project are 
included in raw data view dialogue box. Date in dialogue box only can be viewed, not 
be modified. 
If there is no raw data record before, the view dialogue box will show as below: 

 

No raw data 
15.3.3 Fill-Cut Data 
Click Edit→Fill-Cut Data, as picture “Fill-Cut Data” show: 
User can select the road and chainage needed to view from the “Road name and 
chainage” dropdown list. Corresponding Occ information and each transect point 
observing information would be showed at synchronizing data display area downside 
of screen. 
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Notice: Data in dialogue box can only be viewed, not be modified. 

 
Transect observing data 

 
15.3.4 Alignment Data 
Click Edit→Alignment Data, design window for road will pop up, as picture show 
“Road design”. 

 
Road design 

 
In road design window, functions of four icon downside from left to right are: Del.: 
delete the road design data user selects. Edit: edit and modify the horizontal and 
vertical alignment of road user selects. Add: add one road alignment data. Import: 
input road design data from files. (Suffix of road design is rod, please refer to 
“Appendix A: File forms for Engineering genius” about rod form.).Export: export the 
selected road design data and save them as file form. 
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Add road design data:  
    Refer to “Edit→Alignment Data” to get more details 
 
Export road design data: 
Choose the road name needed to export, as picture “Select road” shows. Use pen to 
select the road needed to export from road name list. When one road is selected, chose 
road name would be brighter, and the horizontal, vertical alignment graph would 
display. Click Export, system would pop up a “save as” dialogue box, input the file 
name needed to export at the name box. As: Road 1, as picture showed below: 

 
Select road 

 

 
Export road name 
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Edit road design data: 
 
Refer to “Edit→Alignment Data” to get more details 
 
Delete road design data: 
    Select road name needed to delete from road list, as picture showed “Select road”. 
When one road is selected, chose road name would be brighter, and the horizontal, 
vertical alignment graph would display. Click Del., Notice dialogue box would pop up, 
as picture showed below. OK Delete, X Cancel. 
 
Import road design data: 
    In picture “Road design”, click Import; “Open file” dialogue box would pop up. 
Select the file name needed to import, click Open: 

 
Open file 

 
  If there is same file in imported files as the road name in road name list, dialogue 
“Same road name” would pop up automatically, and modify the road name in 
imported files. OK Continue, X Cancel. 
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Same road name 

15.4 S.O. menu 

 
S.O. menu 

 
Notice: Before Setout starts, user must complete setting Occ correctly. If still not set 
Occ, system will notice that needing user to set Occ first when any Setout function is 
clicked. Showed as picture” Set Occ notice” 
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Set Occ notice 

 
Select “OK”, system would enter into Occ set automatically, if choose “X”, system 
would give up setting Occ and turn back to main menu directly. 
 
 
15.4.1 Radiate Setout 
Function: set equipment at one reference point, get accurate position information of 
known point according to the angle from the line passes through known point and Occ 
to zero direction of Occ and the distance from Occ to known point. 

 
Radiate Setout 

 
Click Select at rightside of Setout point input box, Setout point choosing dialogue box 
would pop up under the Setout point input box, as below: 
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Refer to “S.O.→Radiate” to know more about details. 
 
15.4.2 Setout point 
Click S.O.→Point. As picture “Setout point menu” showed. 
Refer to “S.O.→Point” to know more about details. 

 
Setout point menu 

 
15.4.3 Setout line 
Click S.O.→Line. As picture “Setout line menu” shows. 
Refer to “S.O.→Line→Poly Line”, “S.O.→Line→Arc” to know more about details. 
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Setout line menu 

 
15.4.4 Setout plane 
Click S.O.→Plane. As picture “Setout plane menu” showed. 
Refer to “S.O.→Plane→Slope”, “S.O.→Plane→3 points-plane”, “S.O.→Plane→Arc 
plane” to know more about details. 

 
Setout plane menu 

 
15.4.5 Road design 
As picture shows “Road Setout menu”. Click S.O.→Road layout, graph showed as 
below: 
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Road Setout menu 

 
Road Setout 

Refer to S.O.→Road layout to know more details about Setout. 
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15.5 Tool menu 

 
Tool menu 

 
 
 
 
 
 
 
15.5.1 COGO 

 
COGO menu 

 

 81 



WinEG2007 

In WinMG2007 software, COGO contains Forward Intersection, Resection, Linear 
Intersection, Angle Intersection, Radiate, Foot of perpendicular, Distance line, Lines 
Intersection, Point on line, Symmetry point eleven coordinate calculating functions. 
Each coordinate calculating function has simple picture to instruct. System supplies 
manually input, capture on screen with pen and select from coordinate list three types 
methods to input point number at every place where to input point number. 
If coordinate has already existed at the point we need to calculate, software will 
reserve a coordinate data which has same coordinate with the existed point. And the 
point number of that new point will be equal to the sum of the max number of existent 
point number plus one. Software will show the notice of failure if there is no such 
intersection.  
 
Forward intersection 
According to forward intersection, we have point 1, point 2, both of them are known 
points. Set occupation at these two points and get value of ∠1, ∠2, to calculate 
unknown point P. The mathematical model as below: 

 

 
As picture ‘Forward intersection’ shows, point 1 and point 2 are known, input angle 
value and click OK. Point position will be shown on the screen, new point number 
will be equal to the sum of the max number of existent point number plus one. As 
No.5 point in picture ‘Forward intersection results’. 
Notice: The intersection points locate in the leftside of the direction of forward 
motion. 
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Forward intersection 
 

 
Forward intersection results 

 
Resection 
According to resection, we need three known points 1, 2, 3, two known angles α β, 
click OK. Intersection position will be shown on screen, new point number will be 
equal to the sum of the max number of existent point number plus one. As point 6 in 
picture ‘Resection results’. 

 
Resection 
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Resection results 

 
Linear intersection 
According to linear intersection, we need to set occupation at point P, get two 
distances from point P to point 6 and to point 1, to calculate coordinate of point P. 
As picture ‘Linear intersection’ shows, point 1 and point 6 are known points, input the 
distances from two known points to intersection point P. Click OK, Dialogue will 
show P number as 7.Point P position will be shown on screen m and new point 
number will be equal to the sum of the max number of existed point number plus one. 
Shown as point 7 in the picture ‘Linear intersection results’. 
Notice: The intersection points locate in the leftside of the direction of forward 
motion. 

 

Linear intersection 

 84 



WinEG2007 

 
Linear intersection results 

 
Angle intersection 
In practical measuring, some problems like finding no place to put prism will appear. 
If unknown point and the two known points are on same line, you can use this 
function to get point P. 

 
Angle intersection 

 
As picture ‘Angle intersection shows points 4, 6 are known, Point 1 is occupation 
point, point 3 is back point. Input turn angle α and click OK to calculate point P. 
Dialogue box will show intersection number as 8 points position will be shown on 
screen. New point number will be equal to the sum of the max number of existent 
point number plus one. As 8 points in the picture ‘Angle intersection results’. 
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Angle intersection 

 
Vertical distance point 
Point A, point B are known, distance between B and foot is S1, the distance from 
unknown point P to the line pass through point A and B is S2, to get point P 
coordinate. 

 
Vertical distance point 

As picture ‘Vertical distance point’ show, point 1 and pint 2 are known, input distance 
S1, S2, click OK and get coordinate of point P. Point P’s number is 4.Position of it 
will be shown on screen. New point number will be equal to the sum of the max 
number of existent point number plus one. Shown as point 4 in picture’ Vertical 
distance point results’. 
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Vertical distance point results 

 
Notice: When the sequence of point 1 and point 2 is counterclockwise rotation, let S1 
be positive value, otherwise be negative value. When foot is located between two 
known points or on the extending line for the opposite direction of the straight line, S2 
should be positive value. When it’s located just on the extending line for opposite 
direction of the straight line, S2 should be negative value. 
 
Radiate 
Point A and B are reference points, set occupation at A and set B as start direction, get 
horizontal angle and distance S by measuring, to calculate point P coordinate. Show as 
picture ‘Radiate’. 

 
Radiate 
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Set occupation at point 1, set point 2 as start direction, input the distance from pint 1 
to point P and horizontal angle α, click OK, then get coordinate of point P. Point 
number of P point is 5,position will be shown on screen. New point number will be 
equal to the sum of the max number of existent point number plus one. As point 5 in 
picture ‘Radiate results’. 

 
Radiate results 

 
 
Foot of perpendicular 
Points A, B, C are known points, make C as reference point, to calculate point P which 
is foot of perpendicular for line AB and point C. 
As picture ‘Foot of perpendicular’ show, straight line pass through point 1 and point 2, 
point 5 is reference point, click OK ,then could get point P. Position is shown on 
screen. New point number will be equal to the sum of the max number of existent 
point number plus one. As point 6 in picture ‘Foot of perpendicular results’. 
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Foot of perpendicular 

 
Foot of perpendicular results 

 
Distance line 
Point A, B, C are all known points, AB is a straight line, S is a distance needed to join 
calculation, to get the point which is on AB line and the distance from which to point 
C is S. 
As ‘Distance line’ show, a straight pass through point 1 and 2.Input distance from 
unknown point to point 5, click OK to get point P. Position will be shown on screen. 
New point number will be equal to the sum of the max number of existed point 
number plus one. As point 7 in picture ‘Distance line results’. 
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Distance line 

 
Notice: According to the limitation of known conditions, this method would produce 
two intersections, our software will judge by choosing the one which is far from first 
point. When operator needs to get another point, you can change the sequence of point 
1 and 2. 
 

 
Distance line results 

 
 
Lines intersection 
There is one line passing through point A and point B, and another one passing 
through point C and point D, to calculate the intersection pint P of these two lines. 
As ‘Lines intersection’ show, one line passes through point 7 and 5 another passes 
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through point 1 and 4. Click OK, intersection P will be calculated. Point’s position 
will be shown on screen immediately. New point number will be equal to the sum of 
the max number of existent point number plus one. Calculation result will be saved 
automatically as point 8. 

 
Lines intersection 

 

 
Lines intersection results 

Notice: when user inputs these four points by sequence, software will judge that 
whether the two lines are parallel, if they are, system would notice that “calculating 
failed, please check input data again.” 
Point on line 
Point A and B are known points, a straight line passes through point A and B, P is 
inside point or outside point on line, S is distance from B to P, to calculate coordinate 
of inside point, outside point P. 
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Point on line 

As picture ‘Point on line’ show, a straight line passed through point 1 and 5, after 
inputting the distance from unknown point to point 5, click OK ,point P will be 
calculated and shown on screen immediately. New point number will be equal to the 
sum of the max number of existent point number plus one. As point 9 in picture ‘Point 
on line results’. 
Notice: If the input distance is positive value, the unknown point is on positive 
extending line of straight line; if the distance is negative value, the unknown point is 
on opposite extending line of straight line. 

 
Point on line results 

Symmetry point 
Point A, B, C are all known points. Line AB passes through point A, B, then calculate 
symmetry point of point C about line AB. 
As picture ‘symmetry point’ show, one straight line passes through point 1 and point 9. 
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Point 4 is reference point. After clicking OK, symmetry point P of point 4 could be 
calculated. Point position will be shown on screen. New point number will be equal to 
the sum of the max number of existent point number plus one. Show as point 10 in 
picture ‘symmetry point results’. 
 

 
Symmetry point 

 
Symmetry point results 

 
 
 
15.5.2 Area computations 
Area computation could calculate area of every closed polygon and area which is 
made by three or more points that not on same straight line. The points could be 
known coordinate points and also could be unknown point in graph. 
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Calculate area made by three points which not on same line: In area computation 
dialogue box, user could input coordinate point by screen capture function with pen. 
Also could use digital keyboard to input coordinate point. If the point is known point, 
the point number would be shown in display window. If the point is an unknown point. 
“-” would display in point number box. As picture “Area computation” described 
below: 

 
Area calculation 

Notice: As the differences of the coordinate point positions, the shape points make can 
be different. As a result, the area would be different too. So user has to input the points 
by correct sequence, in order to get the correct area data you want. 
 
15.5.3 Point in Direction 
Function: Calculate unknown point, according to a known point, HD and azimuth. 
Steps: Click Tool→Point in Direction, showed as graph below: 
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Point in Direction 
Input known point, HD, azimuth and calculate with clicking OK. If select “Save 
calculation point”, this point would be shown on screen and added to project file. As 
graph below showed: 
Known data: Point 1; Azimuth, 180°; HD, 1. as picture showed below: 
 

 
Calculation result 

 
Click to save coordinate, as picture shown below: 

 
Saving coordinate notice 

 
15.5.4 Inverse 

Function: calculate the horizontal distance from Occ to known point and angle 
from known point to BS point with Occ, BS point and one known point. 
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Inverse 

 
Steps: Click Tool→Inverse. Input Occ, BS points, known point and click Calculate to 
get horizontal distance and angle. Shown as the picture below: 
Known data: Occ point 1, BS point 7, and known point 9. As picture “calculation 
result” shown. 

 
Calculation result 
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15.6 Setup menu 

 
Setting menu 

 
15.6.1 System Setup 
Click Setup→System Setup, setting graph dialogue box would pop up, as picture 
“Graph setting”: 

 
Graph settings 

 
Screen capture: The accuracy arrange of screen capture is about 1～10 Pixels. Bigger 
the pixel is, larger the screen capture is. At same time, accuracy of screen capture 
would be lower. In order to reach the requirement of job, user could set the 
arrangement by them. The system default arranges is 5 pixels. 
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Map subdivision: Set the drawing scale and subdivision size, there are 1; 500 1; 1000 
1; 2000 different size and 50×50 50 × 40 different subdivisions to select. The system 
default drawing scale is: 1:1000, man subdivision is: 50×50. 
Coordinate drawing style: Set display type of coordinate. System has None, Pt, Pt 
number, Pt name, Elevation five display types to choose. User could select the display 
type for showing coordinate according to their habit. System display type default is Pt 
name. 
Coordinate selecting type: Set the searching style for choosing coordinate point. 
System has Pt number, Pt name two kinds of searching type to choose. User could 
select the display type for showing coordinate according to their habit. Searching type 
default in system is: Pt name. 
The functions of three icons downside of the window are: 1 Battery capacity: system 
would display battery capacity if this function is activated; 2 North arrow: system 
would display north arrow if this function is activated; 3 Speedy drawing. 
 
 
 
15.6.2 Project information 
Click Setup→Project, System info dialogue box would pop up, as picture shown 
“Project information” 

 
System information 

Saving path, project file name, file version and creating date of project file would be 
included in system info dialogue box. 
 
15.6.3 Setup unit 
Click these two options in turn Setup→Unit Set, “Unit Set” dialog box will be shown 
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as below. User can set the unit of angle, distance, pressure, temperature here. For 
example: when angle unit is set as Gon, distance unit set as Feet, corresponding sets 
would be changed in the whole software.
Note: Once change the unit, system will change all of the data into the data in the unit 
user set.

 
Unit setting 

 
Unit setting options 

   Menu    Selecting Item                  Contents 
1. Ang. Unit Degree/Gon/Mil 

 
Select degree (360°) , gon (400 G) or mil (6400 M) 
for the measuring angle unit to be shown on the 
display 

2. Dist. Unit Meter/Feet/ 
U.S-Feet 

Select the distance measuring unit Meter, Int. Feet 
or U.S Feet. 

3. Temp.Unit / ℃ ℉ Select the temperature unit for the atmospheric 
correction 

4. Pres.Unit mmHg/ hPa/ inHg Select the air pressure unit for the atmospheric 
correction. 

                          Measurement unit setting  
 
15.6.4 Measurement setting 
 
Click these two options in turn: Setup→Measurement Set, “Measurement Set” dialog 
box will be shown as below:

 99 



WinEG2007 

 

 
     Measurement setting 

 
 
Measurement settings: 

   Menu  Selecting 
Item 

             Contents 

1. Tilt OFF/1 axis/2 
axis 

Select the tilt sensor option for OFF, (1 axis) 
vertical only or (2 axis) vertical and 
horizontal 

2. Correction 
for atmosphere 
refraction 

0/0.14/0.20 

Select the coefficient correction for 
refraction and earth curvature. Selections 
for the refraction coefficient are : 
OFF( No Correction ) , K =0.14 or K =0.20 

3.Vertical 
angle model Zenith/Level Select the vertical angle reading for Zenith 0 

or Horizontal 0. 
                             
When Off is chose, Tilt will not be working with the vial plate over the range; When 1 
or 2-axis mode is chose, Tilt will be working automatically with the vial plate over the 
range. And The Tilt dialog box pop up. This dialog box will not disappear until total 
station is leveled. Shown as below: 
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Tilt 

The rest functions are described in Win total station manual specifically, read Win 
total station manual, if want to know more. 

Atmospheric Refraction and Earth Curvature Correction 

The instrument will automatically correct the effect of atmosphere refraction and the 
earth curvature when calculating the horizontal distance and the height differences. 
The correction for atmosphere refraction and the earth curvature are done by the 
formulas as follows: 
Corrected Horizontal Distance; 
 D=S * [cosα+ sinα* S * cosα (K-2) / 2Re] 
Corrected Height Differentia; 
H= S * [sinα + cosα* S * cosα (1-K) / 2Re] 
 
  If the correction of atmosphere refraction and the earth curvature is neglected, the 
calculation formula of horizontal distance and the height differentia are: 
D=S·cosα 
H=S·sinα 
 

In formula:    K=0.14 ……………………Atmosphere Refraction Modulus 

Re=6370 km ………………The Earth Curvature Radius 

Α (orβ) ………………...The Vertical Angle Calculated From Horizontal Plane 
(Vertical Angle) 

S ………………………….Oblique Distance 
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NOTE: The atmosphere refraction modulus of this instrument has been set as: K=0.14. 
It ALS can be set as: K=0.2, or be set shut (0 VALUE). 
15.6.5 Technical supports 
WinEG2007 technical support website, Address: http://www.southinstrument.com 
 
15.6.6 Software information 
WinEG2007 Version, copyright information. 
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Appendix A: File format of Engineering Genius 

*.dat Coordinate data file 
Format of coordinate data file as below; 
Point 1 name, Point 1 code, Point 1 Y（East）coordinate,Point 1 X（North）coordinate, 
Point1 Elevation 
… 
Point N name, Point N code, Point N Y（East）coordinate, Point N X（North）
coordinate, Point N Elevation 
 
Instruction: 
Each line in file indicates one point; Unit of coordinate Y, X, Z of every point is meter; 
comma can not be contained in code. 
 
*.rod   Road data file 
Data file form is as below: 
[HEADER] 
ROADNAME, road1 
VALTYPE, 0 
[END] 
 
[ALIGN] 
START, 300.000, 488342.493, 2552134.180 
STRAIGHT, 30.0000, 500.00000000000 
ARC,-2000.000, 500.000000 
SPIRAL,-2500.000, 300.000000 
Pt, 489996.699, 2558932.226, 3500.000, 300.000, 300.000 
[END] 
 
[VLIGN] 
400.000, 40.000, 60.000 
500.000, 35.000, 50.000 
600.000, 25.000, 70.000 
700.000, 30.000, 60.000 
[END] 
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[SECT] 
400, sect1, sect1 
[END] 
 
[TEMPLATE] 
TEMPLATENAME, sect1, 3 
ZONE, Z1, 1, 12.000, 0.300 
ZONE, Z2, 1, 3.000, 2.500 
ZONE, Z3, 0, 5.000, 0.000 
[END] 
 
Instruction: 
[HEADER] Road information 
ROADNAME, Road name 
VALTYPE, Vertical curve type（0, vertical curve;1, erect curve） 
[END]Road information is over 
 
[ALIGN] Horizontal alignment 
START, Start chainage, East coordinate, North coordinate（Only one start point data is 
allowed） 
STRAIGHT, azimuth, length（straight segment） 
ARC, radius, arc length（Arc section） 
SPIRAL, radius, transition length（transition curve section） 
Pt, coordinate east, coordinate north, radius, last transition length, next transition 
length（point） 
[END] Horizontal alignment is over 
 
[VLIGN] vertical alignment 
chainage, elevation（gradient）, length 
 [END] vertical alignment is over 
 
[SECT] transect 
chainage, transect model name of road leftside, transect model name of road rightside 
[END] transect is over 
 
[TEMPLATE] transect template 
TEMPLATENAME, template name, section number 
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ZONE, section name 1, offset type, horizontal offset, vertical offset 
…… 
ZONE,section name N, offset type, horizontal offset, vertical offset 
 [END] transect template is over 
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Appendix B: Upgrade and install WinEG2007 

We sent along a CD and instruction manual with every total station. You can find 
winMG2007, Microsoft ActiveSync, and driver for Win Total Station on the CD. 
 
1. Install Microsoft ActiveSync and Driver 
Caution: 
 
After the installation of Microsoft ActiveSync, you must restart the computer. We 
suggest that you close all the programs and save your work.   
Connect the computer with Win Total Station, and then you will get a message asking 
for the installation of Drivers. Please download them on the CD attached with total 
station. 
 
2. Install Microsoft ActiveSync 
 
Put the CD in to CD-ROM drivers and run “Microsoft ActiveSync” 
The setup wizard will  you through the process of installation.  guide

After the installation, please restart the computer. 
Connect the computer and the total Station with Communication Cable. 
Then turn on the total station, once the connection is successful, you will get the 

 106 

http://dj.iciba.com/guide/


WinEG2007 

following figure as shown 

 
 

Browse 
 
Click the browse button, then you can see all the data of this connected total station 
and, you can also delete, copy, and move the files. 

 

                                 
3. Installation of Driver for Win Total Station 
 
If you do not have the driver for the Win total station on your computer the connection 
will stop and prompt for it, then follow the setup wizard to finish the installation. 
After the installation, reconnect the computer and the total station. 
 
 
4. Installation of WinEG2007 
After the succeed connection between the computer and the total station, you can 
setup or upgrade the WinEG2007. Click the “setup.exe” under the folder of 
WinEG2007 on your CD, you get the following figure. 
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WinEG2007 installation 1 

 
Click setup as shown in the following figure.; 

 
WinEG2007 installation 2 

 
The setup will cost you 2-5 minutes, then click OK, and finish the installation. 
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PART Ⅱ 

1 Introduction 

WindowsCE operating system Total Station (WINTS for short) has the Graphical User 
Interface (GUI for short) which makes the Total Station very simple and easy to 
operate even who has never used a Total Station before. And that’s why WINTS is one 
of the most popular Total Station. EK is the final data processing software of WINTS 
which has the linetype design, calculation function and data analysis function, it 
makes the Road Design and Construction Work integrated. 
The EK program window is divided into six parts: Menu, Toolbar, Control Panel, 
Information Output Area, Status Bar and View Area, as shown in Figure 1-1 

 
Figure 1-1: Arrangement of the elements in the EK window 

Arrangement of the elements in the EK window: Along the top is the pull-down menu: 
File, Data, Design , Analysis, Tool, Report, View, Help; Below the Pull-down menu 
is the Toolbar: Panel, Prompt, Zoom In, Zoom Out, Pan, Window, Zoom all, 
Previous, Refresh; On the left is the Control Panel: Function, Property, File list;  
Below the Control Panel is the Information Output Area; On the right is the View Area; 
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At the bottom is the Status Bar. 

2 Functions 

2.1 File 
Click File in the menu bar. The list of items appears as shown in Figure 2-1: 

 

Figure 2-1: File Menu 
Functions of the File Menu: 
New: Create a new project file. Input the Project Name, Project Code, Company Info. 
Etc. and choose the Save Path when creating a new project file. Then click OK. 
Open: Open an existing project file (*.prg) 
Save: Save a project (*.prg) 
Save as: Save a copy of the current file with a new file name. (*.prg) 
Coord Input: Import existing coordinate to a project. It has two ways to import 
coordinate: Manual and Auto. Manual allows users to input coordinates by using 
keyboard; the coordinate code will be automatically accumulated. Auto allows users to 
import coordinates automatically by using coordinate files. (*.dat) 
Note: For details about *.dat data format please see the “Appendix A: Data Format” 
Coord Output: Export the coordinate data from current project to a *.dat file. 
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Export settlement data: Export the Last Settlement Data, Users can specify which 
coordinate need to export and its saving path, note, etc. The exported file will be saved 
in *.txt format. 
Import settlement data: Import the Former Settlement Data. Users can Import an 
existing settlement data into a project. (*.txt ) 
Export to EXCEL: Export the data file into EXCEL. 
Print: Print data report, data analysis etc. 
Print Preview: Preview the print result. 
Print Setup: Setup the printer and papers. 
Exit: Close the EK program. 
2.2 Data 
Click Data in the menu bar. The list of items appears as shown in Figure 2-2: 

 

Figure 2-2: Data Menu 
Functions of the Data Menu: 
Coord Data: Display the View Coordinate dialog. You can view, modify and delete the 
coordinate data. 
X-Sect: On the right shows the transect data as shown in Figure 2-3. Choose different 
Occupied Point, the Coordinate, Back Sight Point Coordinate, Total Station Height, 
Horizontal Angle, Slope Distance and Zenith of the selected Occupied Point will be 
shown. You can modify and save the information. 
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Figure 2-3: Transect Data Menu 

 
2.3 Design 
Click Design in the menu bar. The list of items appears as shown in Figure 2-4: 

 
Figure 2-4: Design Menu 

Functions of the Design Menu: 
Road Curve Design: Curve Calculation. It can calculate these linetypes: Single cross 
plane curve, Convexity plane curve, Tangent base line plane curve, Complex base line 
plane curve, S type plane curve, Egg type plane curve. The calculation result can be 
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exported into an EXCEL file. Road Curve Design is corresponding to Route 
calculation in the control panel. You’ll get more details about these commands in later 
sections. 
Chainage Calculation: Based on the Number of the starting Stake, Curve Parameter, 
Curve Start Point, etc, input the space between the stakes, the program will work out 
each coordinates of the stakes. The result can be exported into an EXCEL file. 
Chainage Calculation is same as the Chainage Calculation in the control panel. You’ll 
get more information in later sections. 
Road Design: Create new lines or clear the old lines. This function includes 
Horizontal alignment design, Transect design and Road Calculation, etc. You’ll get 
more information in later sections. 
 
2.4 Analysis 
Click Analysis in the menu bar. The list of items appears as shown in Figure 2-5: 

 
Figure 2-5 Analysis Menus 

Functions of this Menu: 
Cross Section Analysis: Compare the transect design and transect survey result. Select 
the line which you want analysis first, then choose transect design (display as red line) 
then choose transect survey result (display as blue line); the compared result can be 
printed out, as shown in Figure 2-6. 
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Figure 2-6: Cross Section Analysis 

Sedigraph: Display the Settlement Curve, Point Position and Point Movement Curve. 
Click Sedigraph, the system shows “None Settlement Data imported, import it now?” 
Click “OK” to show “Open” dialog, User can now import Settlement Data (*.txt 
format, user can import several data files at the same time). After importing, user can 
choose Sedigraph, Displacement C and Point variation; the result can be printed out, 
as shown in Figure 2-6: 
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Figure 2-6: Sedigraph 

 
On the right the six numbers: 1, 2, 3, 4, 5, 6 means six observation points. Figure 2-6 
shows six settlement curves at the same time, if user only wants to display one of 
these curves, just remove the “√” in front of other numbers. 
 
Choose Displacement C, The View Area will display the first Displacement Curve as 
default, as shown in Figure 2-7. The result can be printed out.  
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Figure 2-7: Displacement Curve 

Choose Point variation, The View Area will display the first Point Variation Curve as 
default, as shown in Figure 2-7. The result can be printed out.  

 
Figure 2-8: Point Variation 
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2.5 Tool 
Click Tool in the menu bar. The list of items appears as shown in Figure 2-9: 

 
Figure 2-9: Tool Menu 

Functions of the Tool Menu: 
COGO: According to some geometry theory and calculating steps, use some known 
points or lines to calculate unknown point or parameter. This command has pull-down 
choices, such as Intersection, Resection, Linear Intersection, Angle Intersection, 
Vertical Distance Point etc. More about these commands will be introduced later. 
Coordinate Transformation: Transform current coordinate system to another 
coordinate system. 
 
2.6 Report 
Click Report in the menu bar. The list of items appears as shown in Figure 2-10: 
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Figure 2-10: Report Menu 

Functions of the Tool Menu: 
Observation: Display the Observation Report in the View Port, including Name of 
Survey Station, Collimating Direction, Right and Left Horizontal Angle, Zenith 
Distance, Slope Distance, etc. The Report will be automatically divided into several 
pages and can be printed out. As shown in Figure 2-11. 

 
Figure 2-11: Observation Report 

 118 



WinEG2007 

Coordinate: Display the Coordinate Report in the View Port, including Point Name, 
Point Code, NEZ Coordinate, etc. The Report will be automatically divided into 
several pages and can be printed out. As shown in Figure 2-12. 

 
Figure 2-12: Coordinate Report 

Settlement: Display the Settlement Report in the View Port (Import the Settlement 
Data first). The Settlement Report will be displayed by stages, including Elevation, 
Settlement of Current period and Accumulated Settlement. The Report will be 
automatically divided into several pages and every page is divided into four stages. 
The Report can be printed out, as shown in Figure 2-13. 

 
Figure 2-13: Settlement Report 
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Displacement: Display the Displacement Report in the View Port (Import the 
Settlement Data first). The Displacement Report will be displayed by stages, every 
stage includes Coordinate, Current Displacement and Accumulate Displacement. The 
Report will be automatically divided into several pages and every page will be divided 
into four stages. The Report can be printed out, as shown in Figure 2-14. 

 

Figure 2-14: Displacement Report 
Setup: Setup the path of Report Template and exported Rows (The Observation 
Report set 22 rows as default, The Coordinate Report set 45 rows as default), as 
shown in Figure 2-15. The Report can’t be displayed without a right Template Path. 
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Figure 2-15 Setup 

2.7 View 
Click View in the menu bar. The list of items appears as shown in Figure 2-16: 

 

Figure 2-16 View Menu 
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Functions of the View Menu: 
Tool Bar: Open or Close the Tool Bar. 
Status Bar: Open or Close the Status Prompt. 
2.8 Help 
Click Help in the menu bar. The list of items appears as shown in Figure 2-17: 

 
Figure 2-17 Help Menu 

Functions of the Help Menu: 
About EK: You can view information about EK. As shown in Figure 2-18. Click OK 
to exit. 

 
Figure 2-18 About EK 

Online Support: Enter the http://www.southsurvey.com to get help. 
2.9 Toolbar 
Functions of the Tool Bar: 
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Open or Close the 
Control panel  

Open or Close the 
Prompt panel 

 Zoom In  Zoom Out 

 Pan  Zoom Window 

 Zoom all  Previous 

 Refresh   

2.10 Control Panel 
Functions of the Tool Bar, as shown in Figure 2-19 

 
Figure 2-19 Control Panel 

Function: Corresponding to the functions of Design, Analysis, Tool and Report menu. 
Property: Check the project information in this panel, double click on the subject 
which you want to modify. 
File list: Check the file information of current project, Click on the file which you 
want to check, the result will be displayed in the View Area. You’ll get more 
information about file format in later sections. 
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2.11 Information Output Area 
    Display the operations you have done at different time. As shown in Figure 2-20 

 
Figure 2-19: Information Output Area 

3 Road auxiliary computation 

3.1 Single intersection plane curve 
The calculation of single crosspoint plane curve is based on two or three of Option, 
Off angle, External spur, Tangent, Tangent vertical dist., Normal vertical dist. to 
calculate the off angle of curve, external distance, radius of circle curve, circle curve, 
tangent, length of transition curve and length of curve etc. Interface as shown in 
figures 3-1. 

 
Figure 3-1 Single crosspoint for curve  
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Input transition curve length first. If the length is known, input to the dialog box 
directly; If it is unknown, choose Linearity, after choosing Linearity, textbox of 
transition curve become gray, according to other known factors the program will 
calculate the best transition curve length. The following example is supposing that 
the length of transition curve is known. 

Choose external spur in Option and input off angle and external spur, other dialog 
boxes become gray. The unit of off angle is degree, minute, second, as 16°10′35.1″, 
input 16.10351; the unit of external spur is meter. After inputting the data, click Calc., 
the result is displayed, as shown in figure 3-2: 

 
Figure 3-2 Single crosspoint for curve——external spur 

Choose Tangent in Option and input off angle and tangent, other dialog boxes 
become gray. After inputting known data, click Calc., then the result is displayed, as 
shown in figure 3-3:   
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Figure 3-3 Single crosspoint for curve——Tangent 

Choose Vertical distance in Option and input Off angle, Tangent vertical dist. and 
Normal vertical dist., other dialog boxes become gray. After inputting the known data, 
click Calc., the result is displayed, as shown in figure 3-4: 
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Figure 3-4 Single crosspoint for curve ——vertical distance 

If you want to save the result, please click Export EXCEL, then input the name and 
save the file. If you want to cancel, click cancel to quit the current interface. 

3.2 Convex plane curve 
Convexity plane curve is a curve combined by two transition curves which have no 
circle curve to join up. According to some known conditions such as Option, external 
spur and tangent, the calculation of Convexity curve is to calculate off angle, tangent, 
radius of circle curve, transition curve and curve length. The interface of Convexity 
curve is shown as figure 3-5. 
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Figure 3-5 Convexity curve 

Choose external spur in Option, input Curve off angle and External distance, then 
click Calc., the result will be displayed, as shown in figure 3-6: 

 

Figure 3-6 Convexity curve——external spur 
Choose tangent in Option, input Curve off angle and External distance, then click 
Calc., the result will be displayed, as shown in figure 3-7: 
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图 3-7  Convexity curve——tangent 
If you want to save the result, pleas click Export EXCEL, then input the name and 
save the file. If you want to cancel, click cancel to quit the current interface. 

3.3 Baseline tangent plane curve 
If the crosspoint can’t be set because of the terrain or some obstacles, you can choose 
crosspoints of two circles to set a reference line and to replace a crosspoint laydown 
curve, this is called double crosspoints plane curve. If the radius is tangent to reference 
line, it forms the tangency base line plane curve. According to Curve LS, Off JA, 
Base line and Off JB, the calculation of tangency base line plane curve calculates out 
radius of circular curve, length of circular curve, former tangent, later tangent and 
overall length. The interface of Tangency base line plane curve is as shown in figure 
3-8. 
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Figure 3-8 tangency base line plane curve 

    Choose Linearity, Curve LS textbox become gray, according to other known 
factors the program will calculate the best transition curve. Take curve LS for example, 
input curve LS, off JA, base line, off JB then click Calc., the result will be displayed, 
as shown in figure 3-9: 
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图 3-9 tangency base line for curve 
    To save the result, click Export EXCEL, then input the name and save the file, if 
not, click Cancel to quit current interface. 
3.4 Complex curve 
Circle curve is a plane curve which is combined by two circular curves with different 
radiuses but same direction. According to off JA, former curve, off JB, Later curve, 
Baseline and Former radius, the calculation of complex curve calculates out radius of 
later circular curve, length of former circular curve, later circular curve, former 
tangent, later tangent and overall length. Complex curve is shown as figure 3-10. 

 

Figure 3-10 Complex curve 
After inputting off JA, former curve, off JB, Later curve, Baseline and Former radius, 
click Calc., the result will be displayed. If select Adjust former radius, the best radius 
of former circle will be calculated, if not, the calculation will use the user input value. 
As shown in figure 3-11: 
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图 3-11 Complex curve 

If you want to save the result, click Export EXCEL, then input the name and save the 
file. If not, click Cancel to quit current interface. 
 
3.5 S-shape plane curve 
Circle curve is a plane curve which is combined by two circular curves with different 
radiuses and opposite direction. According to Off JA, Former curve, Off JB, Later 
curve, Intersection distance and Former radius, the calculation of S curve calculates 
out radius of later circular curve, length former circular curve, later circular curve, 
former tangent, later tangent and overall length. S curve is shown as figure 3-12. 
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Figure 3-12 S curve 
Input Off JA, Former curve, Off JB, Later curve, Intersection distance and Former 
radius then click Calc., the result is displayed. If choose Adjust former radius, the 
best former circular radius will be calculated, if not, the calculation will use the user 
input value. As shown in figure 3-13: 
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Figure 3-13 S curve 
If you want to save the result, click Export EXCEL, then input the name and save the 
file, if not, click Cancel to quit current interface. 
 
3.6 Egg-shape plane curve 
Insert a transition curve into two circular curves to make curvature gradually change, 
this is oviform plane curve. According to Off JA, Former curve, Off JB, Later curve, 
Baseline and Former radius, the calculation of oviform plane curve calculates out 
radius of later circular curve, former circular curve length, later circular curve, middle 
transition curve, former tangent, later tangent and overall length. Oviform for curve is 
shown as figure 3-14. 

 

Figure 3-14 oviform for curve 
Input Off JA, Former curve, off JB, Off JB, Later curve, Baseline and Former radius, 
then click Calc., the result will be displayed. As shown in figure 3-15: 
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Figure 3-15 oviform for curve 

If you want to save the result, click Export EXCEL, then input the name and save the 
file, if not, click Cancel to quit current interface. 
 
3.7 Over width & over height 
Widen and superelevation is based on Raw data, Widen and Superelevation to 
calculate superelevation value of a certain middle stake’s outside roadbed, of a road’s 
middle line, or of an inside roadbed. Raw data includes: ZH chainage, HZ chainage, 
Curved width, SL curve, Curved SL slope%, Crown slope%, Shoulder slope%, 
Shoulder width and Road width; Widen: Line scale, High order parabola; 
Superelevation: Centre shaft rotation, Inside axis rotation. The interface is shown as 
figure 3-16. 
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Figure 3-16 widen and superelevation 

Input Raw data, suppose Widen as High order parabola, Superelevation as Centre 
shaft rotation, then input Middle chainage, click Calc., the result will be displayed, as 
shown in figure 3-17: 

 
Figure 3-17 widen and superelevation 
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If to save the result, click Export EXCEL, then input the name and save the file, if not, 
click Cancel to quit current interface. 

4 Road chainage calculation 

4.1 Single intersection plane curve 
According to chainage, increase and other known factors, Lay single crosspoint plane 
curve calculates chainage coordinate. The interface is shown as figure 4-1. 

 
Figure 4-1 lay single crosspoint plane curve 

Chainage setup: User can setup chainage by intersection point chainage or start point 
chainage; Add integer: According to the start point and increasing space to insert 
chainage, the value of chainage is an integer. 

Para. setup: User must input radius, offA., F curve and L curve of the curve. If you 
want to calculate border, please choose border to activate L off and R off dialog box 
and input the value. If you want to calculate elevation, please choose Height to 
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activate L height and R height dialog box as well as H.Para. button, click H.Para. as 
shown in figure 4-2. 

 

Figure 4-2 H.Para. 
First user has to input information of start point and end point of this segment. If the 
beginning segment is a line, input the chainage and elevation of the start and end 
point of this straightline. If the beginning is a curve, input chainage and elevation of 
start point, and chainage, radius, former longitudinal slope% and later longitudinal 
slope% of end point, then click add para.. Del all is used to delete all information in 
the dialog box on the right. If you want to modify the linetype of a segment, select 
the listed items of this segment in the list box on the right, click modify, after 
modifying click OK. After adding all factors, click Yes to quit. 

NOTE: In parameter setup, value for slope can be plus or minus, plus to ascend, 
minus to descend. 

Known factors: known section start point, known section end point, known section 
azimuth between start point and section point and known section azimuth between 
section point and end point etc. User can input coordinates by manual or automatic. 
Click pick, as shown in figure 4-3, double click to choose, after that browse 
coordinate close. 
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Figure 4-3 browse coordinate 

Save para.: save all the parameter to the file, click save to save, the default name is 
“Untitled” and the format is *txt; If you want to use the same parameter click pick 
para. to open the file. 
Note: In parameter setup, value for slope can be plus or minus, plus for right in 
forward direction, minus for left in forward direction. 

After setting parameter, click Calc., the result is displayed in dialog box on the right, 
including curve factor, chainage and coordinate of key points (ZH, HY, QZ, YH, HZ) 
and of each inserted chainage. This software has Add chainage function, input the 
chainage to be added Add, then calculated information of of the added chainage will 
be displayed in the list box. As shown in figure 4-4. 

Export EXCEL: export result to EXCEL. 
Cancel: Quit the dialog box. 
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Figure 4-4 Lay single crosspoint plane curve 
4.2 Baseline tangent plane curve 
According to Chainage, Increase and other known factors, this function can calculate 
chainage coordinate. The interface is as follow:. 

 

Baseline tangent plane curve 
Chainage setup: User can setup chainage by Intersection point chainage or Start point 
Chainage;  
Add integer: Make the value of start point chainage, insert point chainage and 
increment to be integral. 
Para. setup: You have to input curve Radius, F offA, L offA and Curve L. If you want 
to calculate border, please choose Border to activate L off and R off dialog box and 
input the value. If you want to calculate elevation, please choose Height to activate L 
height and R height dialog box, at the same time, H.para. also is activated. Click 
H.para.. 
Known factor, Save pare., Pick para., Calc., Add, Export EXCEL are same as lay 
single intersection plane curve. As following figure: 
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 Baseline tangent plane curve 

    You can move scroll bar up, down, left or right to view the information, click 
Cancel to escape. 
4.3 Complex curve  
According to chainage, increase and other known factors, this function can calculate 
chainage coordinate. Interface is as following figure: 
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Complex curve 

The differences between complex curve and single intersection plane curve are F 
radius, F offA, L radius, L offA, F curve, L curve must be input in Para. setup. 
Others are same as single intersection plane curve. Example for calculation with 
complex curve is as following graph: 
PS: Former radius and later radius must be the same plus-minus. 
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Complex curve 

You can move scroll bar up, down, left and right to view the information, click Cancel 
to quite. 
4.4 S-shape plane curve 
According to Chainage, Increase and other known factor, this function calculates 
chainage coordinate. Interface is as following figure: 
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S-shape plane curve 

    From interface S-shape plane curve is almost the same as single intersection 
plane curve, but a little different, the former radius and later radius must be opposite. 
S-shape plane curve is as follows: 
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S-shape plane curve 
User can move scroll bar to up, down, left and right to go over the information, click 
Cancel to escape. 
4.5 Egg-shape plane curve 
According to Chainage, increase and other known factor, this function can calculate 
chainage coordinate. Interface is as following figure: 

 
Egg-shape plane curve 

The difference between Egg-shape plane curve and single intersection plane curve are 
that F radius, F offA, L radius, L offA, F curve, L curve must be input in Para. setup. 
Others are same as single intersection plane curve, egg-shape plane curve is as 
following figure: 
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Egg-shape plane curve 
You can move scroll bar to up, down, left and right to go over the information, click 
Cancel to escape. 
4.6 Vertical curve 

According to Elevation, Radius, F slope%, L slope% and Increase of Start point or 
Knick point to calculate chainage, HD to start point, slope elevation and vertical 
curve elevation..  
Add integer: Make the value of start point chainage, chainage, increment to be in 
tegral. Interface is as following figure: 
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Vertical curve 

After input parameter, click Calc., result lists in the list box. If you want to calculate 
chainage, input the value in Chainage, and then click Add. Shown as following 
figure: 
PS: The unit for former slope and later slope is “%”, for example, former slope is 
0.01%, so input 0.01. Plus for ascend, minus for descend. 

 
Vertical curve 
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User can move scroll bar to up, down, left and right to go over the information, click 
Cancel to quite. 

5 Road theory design 

Click Design——Road Design——Add, it displays “Add road” figure: 

 
Add road 

Take Road name as “zhongshan road”, choose vertical in V-sect type, click “Yes”, 
“zhongshan road” display in the subdirectory of Road theory design, and as follows 
figure 5-2. If there is no road name, system prompts you to input the name, click 
Cancel to quite. If already exist road name, double click road theory design, chose 
road will be open. 
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Road theory design 
5.1 Start point 

Start point can be input manually or by clicking ..., Start chainage must be input 
manually. Click save to save, after inputting. 
PS: No matter manual input or automatic input, you must click “Save” after input. 
The default value: N=0;E=0;Z=0;start chainage=0. 

5.2 Horizontal alignment 
    Horizontal alignment elements contain: chainage of intersection, 
elevation ,length(radius).  

 
Horizontal alignment 

Add: Add more of blank line used for inputting horizon alignment elements. 
Insert: Insert blank line into appointed position, used for inputting horizon alignment 
elements. 
Delete: Delete horizon alignment elements at appointed position. 
Edit: Modify the appointed horizontal alignment elements. 
Click Add, then an interface will pop up. Choose line in horizon alignment element. 
As follows figure 5-3. In “input line”, length: 712.017 m, azimuth: 1.4916 (degree), 
click Yes to save the data. Click Cancel to quite. 
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Input line 

Choose transition curve in “horizon alignment element”, figure 5-4 “input transition 
curve”, Radius: 5500 m, length: 700 m, choose left in Rotate, click Yes to save, click 
Cancel to escape. 

 
Input transition curve 

Choose circle curve in “horizon alignment element”, figure 5-5 “input circle curve”, 
circle radius: 5500 m, circle length: 700 m, choose left in Rotate, click Yes to save, 
click Cancel to quite   . 

 
Input circle curve 

Choose point in “horizon alignment element”, figure 5-6 “input point”. Two ways to 
input point element manual and …. Radius: 100 m, F curve length: 70 m, L curve 
length: 70 m. click Yes to save the data. Click cancel to quite. 
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Input point 

4 kinds of horizontal element are showed in figure “Horizon alignment data”. When 
choose one element in the list box, it shows chainage and azimuth, and chosen curve 
with red line at the right side. You can click Edit, Del, Insert to edit the data. 

 
Horizontal alignment data 

5.3 Vertical alignment 
After completing adding information of horizontal alignment elements, you can start 
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to input “Vertical alignment” information. Click Vertical alignment button, graph 
shown as below: 

 
 Vertical alignment 

Vertical alignment elements contain: chainage of intersection, elevation, length 
(radius). 
Add: Add more of blank line used for inputting vertical alignment elements. 
Insert: Insert blank line into appointed position, used for inputting vertical alignment 
elements. 
Delete: Delete vertical alignment elements at appointed position. 
Save: Record the input vertical alignment elements. After modifying vertical 
alignment elements, please save before starting other process. 
Click Add, then a blank line exists in the list. Input vertical alignment element data, 
according to the list below. 

  Chainage Elev. Length 
13567.393 49.061 1000 
18200 37.9192 600 
19346.7 33.3893 700 
21447.5 31.2885 1000 

Check the inputting and click Save. And then defining vertical alignment is completed, 
as graph 5-9 shown: 
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    Vertical alignment element data 
5.4 Transect 
After completing adding information of vertical alignment elements, you can start to 
input “Transect” information. Click “Transect” button, graph will show as below: 
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Transect information 
Add: Add more of blank lines used for inputting transect information. 
Insert: Insert blank lines into appointed position, used for inputting transect 
information. 
Delete: Delete transects information at appointed position. 
Save: Record the input transects information. After modifying transect information, 
please save before starting other process. 
Templet: Add new template, view original template or modify existed template. Make 
sure that checking that if the template is existed or not before editing. Define new 
template if there is no template.  
Click Templet, graph as below will show. Template data include: Section name, H 
offset, slope%, V offset, offset type.  

 
Transect templates 

New: Create new transect template, according to input template name. 
Delete: Delete the template chose or has input name. 
Save: Save new or modified transect template data. 
Add section: Add new section of transect template. 
Delete section: Delete chose section of transect template. 
Input at template Name, set, then click Add section, graph 5-12 will show as below. 
Input section name (Default Z1), rest is empty. Input by sequence horizontal offset: 12, 
vertical offset (Slope %): 0.3, click Upward button, button will switch from “Upward”, 
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“Downward” and “Gradient%”.  

 
Add section 

Click Yes, then Z1 section will be added, click X to cancel adding section. Repeat the 
steps above and add the new sections as below: Section name, Z2, Horizontal offset, 3, 
Vertical offset, 2.5, Offset type, down. Section name, Z3, Horizontal offset, 5, Vertical 
offset, 0, Offset type, up. Section name, Z4, Horizontal offset, 7, Vertical offset, 1.2, 
Offset type, slope%. Click Save at last to complete the data inputting for template 
name. That will show like graph below. Click X to go back to transect main interface. 

 
Inputting data of transect template 

In interface “transect information”, click Add, graph will show as below. Click once 
only when you need to input chainage. 
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Add transect 

Click the blank line on left template or right template, interface for choosing transect 
template will appear, as shown on graph below: 

 

Choosing transect template 
Select “Set” template from the template name list in “Choosing transect template” 
interface. Interface after completing data will show like this graph below “Transect 
template data”. Click Save to save the transect data. 
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Transect template data 

Caution: Template of leftside and rightside can be different and also can be same. If 
they are different, choose different templates in “Choosing transect template” 
interface. 
 
5.5 Calculate road point 
After completing adding the transect information, we can go to calculation of road 
points, click “Calculate road point” button, graph will show as below: 

 

Calculate road point 
Road point include: Middle Pt, Left Pt, Right Pt and transition point, etc. 
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Choose Middle Pt, Right Pt, input the distance to middle line, 5, unit is meter; Left Pt, 
input distance to middle line, 7, unit is meter, Transition Pt, input the distance between 
chainage, 100, unit is meter. Click Calc., system will calculate out that 100 road points, 
between which the distance is 100, all of which are on road middle line. Results will 
be showed as below: 
Caution: Distance between chainage is less than 10 meter. 

 
Road coordinate points 

6 COGO 

In EK software, Cogo contains forward intersection, resection, linear intersection, 
angle intersection, radiate, foot of perpendicular, distance line, lines intersection, point 
on line, symmetrical point, etc eleven coordinate calculating function. 
Each coordinate calculating function has simple picture to instruct. System supplies 
manually inputting and selecting from coordinate list two types methods to input point 
number at every place where to input point number. Software will notice you, if there 
is no intersection. 
 
6.1 Forward intersection 
According to forward intersection, we have point 1, point 2, both of them are known 
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points. Set occupation at these two points and get value of ∠1, ∠2, to calculate 
unknown point P. The mathematical model as below: 

 

 
    As shown in graph 6-1 “Forward intersection”, Point A, B are known points, you 
can input manually, and also can select them from coordinates list. 

 

Forward intersection 
 
 
Suppose that coordinate of A is 0,0, coordinate of B is 90,90, both of α、β are 45. Click 
Calc. button, calculation results will display in list, as shown below with graph 6-2: 
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Forward intersection calculation 

Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.2 Resection 
In resection, points A, B, C are known, angle α, β can be measured, with all the 
conditions above to calculate the coordinate of point P. Point P can not appear on the 
circum circle of A, B, C or near it.  
Suppose that coordinate of point A is 0,0, point B is 90,90, point C is 37.495,64.9433, 
α、β are 12.3451, 34.5543 respectively. Click Calc. button, results will show in list. 
Shown as graph 6-3. 
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Graph 6-3 Resection calculation 

Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.3 Linear intersection 
With Linear intersection, you should set station at point A, B both of which are known, 
with all the conditions above to calculate the coordinate of point P. 
In raw data input, suppose that coordinate A is 0, 0, B is 90.90, length of PA is 90 
meters, length of PB is 90 meters. Click Calc. button, results will show in the list, as 
shown below: 
Caution: In Linear intersection, the intersection point will be the left side of 
forwarding direction. 
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Graph 6-4 Linear intersection calculation 

 
Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.4 Angle intersection 
Angle intersection is to use known directions of two lines to determine the unknown 
coordinate of point. In practical surveying, looking for the place for setting station is 
always a problem. This function is made to deal with this kind of problem. Known 
coordinates of point A, point B, point P is a intersection of line AB and a line that 
cross through station, with all the conditions above to get the coordinate of point P. 
In the process of raw data inputting, suppose that coordinate of station is 0, 76.4544. 
Coordinate of backsight is 37.4950,64.9433. Coordinate of point A is 0,0. Point B is 
90,90. α is 36.2415, click Calc., results will show in the below list. As graph 6-5 
shown:  
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Graph 6-5 Angle intersection calculation 
Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.5 Vertical distance point 
Point A and point B are knew, the distance from point B to foot of it is S1 and the 
distance from point P to the line crosses through point A and B is S2, with all the 
conditions above to calculate the coordinate of point P. 
Suppose that coordinate of point A is 0, 0, B is 90, 90, S1 is 47.5 meters, S2 is 36.3 
meters, click Calc. button, results will show in the list: 
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Graph 6-6 Vertical distance point calculation 
Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.6 Radiation 
 
点 A、点 B 为已知控制点,在点 A 设站,以 B 点为起始方向,观测了水平角 α 和距

离 S,计算 P 点的坐标. 
在原始数据输入中假设 A 点坐标为 0,0;B 点坐标为 90,90; α为 36.4215,度分秒;距
离为 73.3 米, 点击计算按钮,计算结果显示在列表框中,如图 6-7 极坐标计算: 
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图 6-7 极坐标计算 
Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.7 Foot of perpendicular 
Point A, B, C are known points, with these conditions to calculate the foot P of the line 
which connects Point C and line AB in shortest distance. 
Suppose that coordinate of point A is 0, 0, B is 90, 90, C is 37.495, 64.943, click Calc., 
results will show in the list below: 
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Graph 6-8 Foot of perpendicular 

Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.8 Lines intersection 
Point A, B, C, D are known points, with these conditions to calculate the intersection P 
of line AB and line CD. 
Suppose that coordinate of point A is 0, 0, B is 90, 90, C is 37.495, 64.943, D is 0, 
76.454, click Calc., results will show in the list below: 
Caution: Each line points you input will be check by system automatically to see that 
if the lines you input are parallel, if they are, system will notice you that “calculating 
failed, please check your data again”. 
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Graph 6-9 Lines intersection 

Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.9 Symmetry point 
Point A, B, C are known points, line AB is a known line, to calculate the symmetrical 
point of C. 
Suppose that coordinate of point A is 0, 0, B is 90, 90, C is 37.495, 64.943, click Calc., 
results will show in the list below: 
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Graph 6-10 Symmetrical point 
Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.10 Point on line 
Point A, B are known points, line AB is a known line, point p is on line AB or on the 
extension line of line AB. S is the distance between point B and point P, to calculate 
the coordinate of point P. 
Suppose that coordinate of point A is 90, 90, B is 37.495, 64.9433, Sbp is 76.3 meters, 
click Calc., results will show in the list below: 
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Graph 6-11 Point on line 

Click Export EXCEL, name the saved file and click Yes, calculation results will be 
saved into EXCEL file. 
6.11 Distance line 
Points A, B, C are known points, line AB is known line, distance S is knew, to 
calculate point located on line AB and from which to C, the distance is S. 
Suppose that coordinate of point A is 0, 0, B is 90, 90, C is 37.495, 64.943, Scp is 
43.27 meters, click Calc., results will show in the list below: 
    Caution: According to the limitation of known conditions, this method would 
produce two intersections, our software will judge by choosing the one which is 
farthest from first point. When operator needs to get another point, you can change the 
sequence of point A and B. 
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Graph 6-12 Distance line 

6.12 Coordinate transformation 
Coordinate transformation is to transform the known coordinate to other kinds of 
coordinate system by moving, rotating, according to some known transformation 
parameters. Main interface of coordinate transformation is as graph 6-13 below: 
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Graph 6-13 Coordinate transformation 
Transform: Pan, Rotation and Parallel rotation 
Parameter: When transform type is Pan, parameter are azimuth and distance. When 
transform type is rotation, parameter are rotation angle and basic point. When 
transform type is parallel rotation, parameter is rotation angle and origin point. 
Pick: Open coordinate view window to add coordinates. 
Add:Add the coordinates to list as the data before transforming. 
Batch add:  add all the data recorded in system to list. 
Batch import: Open appointed files and add all the data in the file to list. 
Delete list: Clean out the data existed in list. 
Export EXCEL: Save the results into EXCEL file. 
Transform: Transform according to raw data and transformation parameter.  
Cancel: Quit dialog box of coordinate transformation 
    For example, select “Parallel rotation” from transform type list. Corresponding 
parameter will change to rotating angle, origin△X, origin△Y. Input 35.2457 as 
rotating angle, 153.24 as origin△X, 72.51 as origin△Y. Click Batch add to add the 
coordinate file to list, then click Transform button, results will display in list of 
Results list box. Shown as below: 

 

Graph 6-14 Coordinate transformation——Parallel rotation 
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7 System file 

Click File option in control area, “Project file list” will show as graph 7-1 below: 

 
Graph 7-1 Project file list 

The file suffix of which is *.coo, is coordinate file. That includes point No., point 
name and coordinates X, Y, Z. While you select “atest.coo” file, all the coordinate file 
will display in the right area. Shown as graph below: 
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Graph 7-2 *coo file 

Customer can modify the coordinates when the file is open. Click twice the data you 
need to modify, then you will be allowed to edit. Notice that Pt No. and Pt name can 
not be modified. Click Save after modifying. 
The file suffix of which is *.daw is used for saving information of ground object. 
While you select “atest.daw” file, all the information included in the file can be 
displayed at right area of window. You can check the information shown as below: 
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Graph 7-3*daw file 

The file suffix of which is *.prj is graphics file. While you select “atest.prj” file, graph 
will display at right area of window. Shown as below: 
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Graph 7-3*prj file 

The file suffix of which is *.prj is used for recording raw data which includes 
information of station point, backsight point and horizontal angle, zenith, SD, prism 
height of each observing point. While you select “atest.raw” file, file contents will 
display at right area of the window. Customer can view the information as below: 
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Graph 7-4*.raw file 

The file suffix of which is *.rod is used for recording information of horizontal 
alignment, vertical alignment and transect template. While you select “atest.rod” file, 
file contents will display at right area of window. Customer can view the information 
as below: 
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Graph 7-5*.rod file 

File suffix which is *.sct is main information of recorded station, orientation point and 
sight point. While you select “atest.sct” file, file contents will display in right area. 
The information you can view is as below: 
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Graph 7-6*.sct file 

 
 
 
 
 

Appendix A:File forms of EK 

*.dat Coordinate data file 
Form of coordinate data file as below: 

Point 1 name,Point 1 code,Point 1 Y（East）coordinate,Point 1 X（North）
coordinate,Point 1 Elevation 

… 

Point N name,Point N code,Point N Y（East）coordinate,Point N X（North）
coordinate,Point N Elevation 

Instruction: 
 Each line in file indicates one point; Unit of coordinate Y, X, Z of every point is 
meter; comma can not be contained in code. 
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*.rod Road data file 
Data file form is as below: 
 [HEADER] 
ROADNAME,road1 
VALTYPE,0 
[END] 
 
[ALIGN] 
START,300.000,488342.493,2552134.180 
STRAIGHT,30.0000,500.00000000000 
ARC,-2000.000,500.000000 
SPIRAL,-2500.000,300.000000 
Pt,489996.699,2558932.226,3500.000,300.000,300.000 
[END] 
 
[VLIGN] 
400.000,40.000,60.000 
500.000,35.000,50.000 
600.000,25.000,70.000 
700.000,30.000,60.000 
[END] 
 
[SECT] 
400,sect1,sect1 
[END] 
 
[TEMPLATE] 
TEMPLATENAME,sect1,3 
ZONE,Z1,1,12.000,0.300 
ZONE,Z2,1,3.000,2.500 
ZONE,Z3,0,5.000,0.000 
[END] 
 
Instruction: 
[HEADER]Road information 
ROADNAME, Road name 
VALTYPE, Vertical curve type（0,vertical curve;1,erect curve） 
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[END]Road information is over 
 
[ALIGN]Horizontal alignment 
START, Start chainage,East coordinate,North coordinate（Only one start point data is 
allowed） 
STRAIGHT, azimuth, length（straight segment） 
ARC, radius, arc length（Arc section） 
SPIRAL, radius,transition length（transition curve section） 

Pt, coordinate east,coordinate north,radius,last transition length,next transition length
（point） 

[END]Horizontal alignment is over 
 
[VLIGN] vertical alignment 
chainage, elevation（gradient）,length 
 [END] vertical alignment is over 
 
[SECT] transect 
chainage,transect model name of road leftside, transect model name of road rightside 
[END] transect is over 
 
[TEMPLATE] transect template 
TEMPLATENAME, template name, section number 
ZONE, section name 1,offset type,horizontal offset,vertical offset 

…… 

ZONE, section name N,offset type,horizontal offset,vertical offset 
 [END] transect template is over 
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